Jump to content

PC/Win7 doesn't like 'waking up' after sleep mode


Javioli
 Share

Recommended Posts

I use Win7 64-bit Ultimate and often I'll ask it to 'sleep' so it powers off but can power back up quickly.

A week or so ago it started having trouble waking up properly - the mouse cursor would be extremely laggy, pressing Alt-Ctrl-Del would take up to 30 seconds to do anything, it wouldn't want to shut down properly, etc. etc. etc.

I've not updated any drivers recently (I keep my video drivers up to date but last update was last month). Windows Updates are automatic however and they install when they want to.

Any ideas what might be causing this?

PC Spec;

ABIT IX48-GT3 Socket 775

Intel Core2Quad Q9400 (2.66Ghz) (2×3 MB L2, 1333 MHz FSB, 95W TDP)

8Gb Corsair TwinX DDR3 1333

XFX ATI Radeon HD 5870 1024

SATA hard drives

SATA (Lightscribe) burnerWin7 Ultimate 64-bit

Link to comment
Share on other sites

Firstly, I am no computer expert. I can't say exactly what it is that is likely to be causing the slow speed. I would, however, recommend some type of computer maintenance program.

I personally use TuneUp Utilities and find it to be very effective in speeding things up. There are plenty of free alternatives out there though.

Link to comment
Share on other sites

I'm not sure it's a clogging up issue, I can replicate the problem by switching it on from cold and putting it in sleep mode when it's done booting.

I do a regular registry cleaning, defrag and also disk cleanup.

Edited by Javioli
Link to comment
Share on other sites

Have you updated it or installed any new software ? with that PC spec you shouldn't be having these types issues ..

Link to comment
Share on other sites

The only new software will have been Windows Updates - which it automatically does whenever they're available.

The PC spec is fine (it's used as a gaming machine / photo editing) and it's only when it wakes up after sleep. It's as if something is stuck in a loop or whatever. I'm no expert in what happens during the sleep process.

Link to comment
Share on other sites

I'm not sure it's a clogging up issue, I can replicate the problem by switching it on from cold and putting it in sleep mode when it's done booting.

I do a regular registry cleaning, defrag and also disk cleanup.

None of those things will do anything to empty the memory cache. IT sounds like a RAM issue.

Link to comment
Share on other sites

The only new software will have been Windows Updates - which it automatically does whenever they're available.

The PC spec is fine (it's used as a gaming machine / photo editing) and it's only when it wakes up after sleep. It's as if something is stuck in a loop or whatever. I'm no expert in what happens during the sleep process.

The simple quick fix would be to not send it to sleep :new_eyebrow: or try a reformat ..

Link to comment
Share on other sites

Do you use Outlook at all? I've recently had problems with it gobbling up loads of resources.

Link to comment
Share on other sites

  • 5 weeks later...

Yeh I use Outlook. But when I close Outlook it drops from Task Manager's list (ie. it doesn't get 'stuck').

Link to comment
Share on other sites

If you have tweaked settings - for example and overclock - it can cause issues with Sleep. I have Sleep always disabled.

I have recently installed a new graphics card which if the monitor goes to sleep won't wake so it shows how fickle PCs are and that isn't even full Sleep mode. Do I now have Sleep disabled and monitor sleep too.

Allegedly this newer problem is due to new Catalyst drivers with AMD cards which you have one of.

Solution disable Sleep mode and monitor sleeping.

Link to comment
Share on other sites

Thanks for your reply.

I don't overclock (CPU or GPU) because I've tried it and never got stable results.

Power saving settings (monitor power off etc) are always disabled.

I'm probably due another PC this year, but my Radeon HD 5870 is still not a bad card. My mate bought a gaming PC recently and his GFX card was about half the power of mine. So the question is whether to keep the GFX card or not.

Link to comment
Share on other sites

Try a full reinstall.

Before you do this download a copy of DriverSweeper (you will get it from Guru3d).

Now go into My Computer and into Remove Programmes and find the AMD programme and delete it.

Reboot.

Now open up DriveSweeper and tick the Ati box and run. (Ideally you do this in Safe Mode but I never bother and it seems to work fine)

Reboot.

Now go into AMD drivers web page and select your OS to see the latest files.

Download only the Catalyst Centre. Install.

Reboot.

Now download the latest drivers - first the one called Cap2 and install and then the Catalyst drivers (currently the beta 12.11) and install

Reboot.

Got into Control Panel and change the Power Settings. You should now be able to let your monitor sleep without it hanging.

(null)

Link to comment
Share on other sites

 Share

×
×
  • Create New...